XserverでWordPressにJetpackを連携できない→エラーの対処法

久しぶりにまともにこのブログをいじって、あちこち忘れてるしバージョンアップで変わってるしで、わちゃわちゃしてる、あんちゃん(@anchan_jp)です。

人生山あり谷あり谷だらけ。平地はないのかい?早速小さな山にぶち当たりましたよ。

一旦WordPressとJetpackの連携切ったら、連携できなくなったじゃないかぁあ!困った困った。

ググるしかない

わからないことはGoogle先生に聞きなさいと、遠い昔におばあちゃんが言っていました。嘘ですけどね。

なので、ちょっとググってみたら、同じ症状の方がいて、しかも解決していました。

XserverのWordPressがJetpack連携できなかったらそれは…

なんのことはない、「XML-RPC API アクセス制限」が邪魔しているだけでした。

XML-RPC API アクセス制限をオフ

Xserverの管理画面にログインして、WordPressセキュリティ設定を開き、XML-RPC API アクセス制限をオフにします。

XML-RPC API アクセス制限

これをオフにしてから、WordPressでJetpackとの連携作業をするとうまくいきました。

さいごに

連携作業が終わったら、忘れずにオンにしておきましょう。

こうやって、解決法を書いてくれている人がいると、ホント助かります。

よかったよかった、ありがとうございました。